pscoast error

Added by Sam over 5 years ago

Hi there,

I'm running GMT 5.1.2 and when I try to execute pscoast (or gmt pscoast) the following is returned:

pscoast: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
pscoast: Could not find file [GSHHG low resolution shorelines]
pscoast: No GSHHG databases available - must abort

My ConfigUser.cmake file contains the lines pointing to where the GSHHG data files live on my machine:

#Set path to GSHHG Shoreline Database [auto]:
set (GSHHG_ROOT "/home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3")

#Copy GSHHG files to $/coast [FALSE]:
set (COPY_GSHHG TRUE)

When I built and installed GMT, the following was printed to screen:

*Found GSHHG database : /home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3 (2.3.3, .nc)

"which pscoast" returns:

/usr/local/bin/pscoast

Any help to solve this issue will be greatly appreciated.

Thanks.


Replies (18)

RE: pscoast error - Added by Paul over 5 years ago

Perhaps you have more than one GMT version installed in your path (i.e., did you install TM% in /usr/local/bin)? Does pscoast - return the expected version number 5.1.2_r13xxx for some xxx? If wrong version then you will need to change your path or use gmtswitch to manage several versions. Did it use to work and suddenly it failed (what changed)? If is this the first time after installing? If you run ls -l /home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3 do you get the listing of all the binned_GSHHS_?.nc files and you have read permission for these?

RE: pscoast error - Added by Sam over 5 years ago

Hi Paul,

I have been using GMT for about a month now (since when I first built and installed it) and I've not been able to get pscoast (or gmtset actually) to work in that time, so nothing has changed.

My binned_GSHHG_?.nc read permissions are all in order.

gmt --version and pscoast --version both return 5.1.2_r13775.

I'm sorry but I don't know what TM% is so perhaps this is the issue?

Cheers.

RE: pscoast error - Added by Paul over 5 years ago

Sorry, the %TM was supposed to be GMT.
I have never used COPY_GSHHG so perhaps that is the problem. Try to remove the build dir and start over with mkdir build, cd build, cmake .. etc after commenting out that statement.
But first, please run
pscoast -Vd -R0/5/0/5 -JM5i -P -W0.25p > t.ps
and tell me if it reports which directories it is trying to find GSHHG in. Then try

pscoast -Vd -R0/5/0/5 -JM5i -P -W0.25p --DIR_GSHHG=/home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3 > t.ps

If the latter works then the COPY_GSHHG did not work properly (did you run your install as root?)

RE: pscoast error - Added by Sam over 5 years ago

pscoast -Vd -R0/5/0/5 -JM5i -P -W0.25p > t.ps
returns:

pscoast: Projected values in meters: -278299 278299 -7.08115e-10 553584
pscoast: 1. GSHHG: GSHHGDIR set, trying GSHHG_PATH-NOTFOUND/binned_GSHHS_l
pscoast: 1. GSHHG: Failure, could not access GSHHG_PATH-NOTFOUND/binned_GSHHS_l
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/conf
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/coast
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: 3. GSHHG: Trying via sharepath
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/coast
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: 4. GSHHG: Failure, could not access any GSHHG files
pscoast: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
pscoast: Could not find file [GSHHG low resolution shorelines]
pscoast: No GSHHG databases available - must abort
pscoast: Entering GMT_Destroy_Session

And,
pscoast -Vd -R0/5/0/5 -JM5i -P -W0.25p --DIR_GSHHG=/home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3 > t.ps
returns:

pscoast: Projected values in meters: -278299 278299 -7.08115e-10 553584
pscoast: 1. GSHHG: GSHHGDIR set, trying /home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3/binned_GSHHS_l
pscoast: 1. GSHHG: Failure, could not access /home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3/binned_GSHHS_l
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/conf
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/coast
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: 3. GSHHG: Trying via sharepath
pscoast: GMT: 1. GMT_getsharepath trying current dir
pscoast: GMT: 4. GMT_getsharepath trying SHAREDIR subdir /usr/local/share/coast
pscoast: GMT: 5. GMT_getsharepath failed
pscoast: 4. GSHHG: Failure, could not access any GSHHG files
pscoast: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
pscoast: Could not find file [GSHHG low resolution shorelines]
pscoast: No GSHHG databases available - must abort
pscoast: Entering GMT_Destroy_Session

I've rebuilt and installed GMT from a new build directory (deleted the old one) and still get the same messages from both pscoast commands.

Not sure about running the install as root sorry, I just followed the build and install steps (http://gmt.soest.hawaii.edu/projects/gmt/wiki/BuildingGMT).

RE: pscoast error - Added by Paul over 5 years ago

Hm, are you running under Cygwin or some odd Linux system? Could you try to run svn update in the top GMT dir? You say you have 5.1.2_r13775 while I have 5.1.2_r13899. After that, run your cmake command again and pay attention to the line
  • Found GSHHG database : /Users/pwessel/GMTdev/gshhg-gmt-2.3.4 (2.3.4, .nc)

(2.3.3 is fine too).
It sounds like yours do not say .nc at the end there, which is what your pscoast messages showed as well.

RE: pscoast error - Added by Sam over 5 years ago

No Cygwin or odd Linux system,

I ran svn update but the version is still 5.1.2_r13775. Running cmake .. etc. from build again returned:

  • Found GSHHG database : /home/ecoast/Documents/000_Software/gmt5-dev/gshhg-gmt-2.3.3 (2.3.3, .nc)

Strange this one...

RE: pscoast error - Added by Paul over 5 years ago

So now it works?

RE: pscoast error - Added by Sam over 5 years ago

Sorry, no still not working.

RE: pscoast error - Added by Paul over 5 years ago

And what does the pscoast command with -Vd say now? Does it report the correct names? What kind of OS do you have?

RE: pscoast error - Added by Sam over 5 years ago

The pscoast command returns the same as before.

My OS is: Linux ubuntumodel2 3.13.0-43-generic.

Perhaps I should remove GMT completely and build/install again?

RE: pscoast error - Added by Paul over 5 years ago

Yes, that would be what I would do. Since we have tons of Ubuntu users (and I am running Ubuntu in dual-boot on an old PC) there must be something odd with your setup, permissions, etc.

RE: pscoast error - Added by Sam over 5 years ago

Ok. Thanks alot for your time.

RE: pscoast error - Added by Sam over 5 years ago

Problem solved!

I updated my cmake from version 2.8.12.2 to version 3.1.0, then rebuilt/installed GMT.

pscoast works like a charm now.

RE: pscoast error - Added by Ladislav almost 5 years ago

In my Ubuntu 14.04, cmake 2.8.12.2 or another component seems to corrupt the GSHHG_ROOT config parameter. A solution via a symlink:

With GSHHG in /opt/gmt/gshhg-gmt-2.3.4 and a line
set (GSHHG_ROOT "/opt/gmt/gshhg-gmt-2.3.4")
in cmake/ConfigUser.cmake,
after cmake, make and make install I get from gmtdefaults
gmtdefaults: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
DIR_GSHHG =
and after
pscoast -Vd -R0/5/0/5 -JM5i -P -W0.25p > t.ps
a message appears:
pscoast: 1. GSHHG: GSHHGDIR set, trying /opt/gmt/gshhg-gmt-2.3.0/binned_GSHHS_l.nc
..
pscoast: 4. GSHHG: Failure, could not access any GSHHG files
pscoast: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
After
ln -s gshhg-gmt-2.3.4 gshhg-gmt-2.3.0
in /opt/gmt, the response to pscoast changes to
pscoast: 1. GSHHG: GSHHGDIR set, trying /opt/gmt/gshhg-gmt-2.3.0/binned_GSHHS_l.nc
pscoast: 1. GSHHG: OK, could access /opt/gmt/gshhg-gmt-2.3.0/binned_GSHHS_l.nc
pscoast: GSHHG version 2.3.4

L.

RE: pscoast error - Added by Paul almost 5 years ago

Did you just update the GSHHG and tried make install? I think you need to remove the build directory and start from scratch so that the Cache files get updated.

RE: pscoast error - Added by Ladislav almost 5 years ago

The build was fresh, the /opt/gmt was fresh, the PATH was clean, but there was left a legacy ~/gmt.conf made by GMT 5.1.1 with the line
DIR_GSHHG = /opt/gmt/gshhg-gmt-2.3.0.
Removing the ~/gmt.conf solves the problem as well (i.e., with cmake 2.8.12.2 and without the symlink).
L.

RE: pscoast error - Added by vivek about 2 years ago

I am using GMT 4.5.17 in Windows platform, And I am getting following error, Could anyone can tell me how could I install GSHHG files in windows platform?

pscoast: Could not find file [GSHHG full resolution shoreline]
pscoast: Could not find file [GSHHG full resolution political boundary data]
pscoast: No GSHHG databases available - must abort

RE: pscoast error - Added by Luis 2 months ago

I see this is an old issue, but I'd been facing this problem and looking for a solution for past 3 days. I finally found a way to solve the problem, although I am not sure whether this solution is universal, it worked for me. This is what I did.

1. Locate where are my binaries
which pscoast
/home/(username)/gmt-4.5.18/bin/pscoast

2. Locate my share directory
/home/(username)/gmt-4.5.18/share

3. I copied the GSHHS files (binned_border_c.nc etc.) I downloaded to from a legacy repository such as http://www.scc.u-tokai.ac.jp/gmt/legacy/ to my share directory (/home/(username)/gmt-4.5.18/share)

I am running GMT 4 on a linux Ubuntu 18.04

Best,
GMT fan

(1-18/18)