gmtinfo on large data sets

Added by John 11 months ago

I believe that gmtinfo is not doing it's job. On a large (23418 records), 6-column data set, essentially, nothing (or strange things) are getting reported.

Specifically, when issuing this command (using the attached gzipped tp.xyz file):

gmt gmtinfo tp.xyz

only the first column range gets reported: tp.xyz: N = 23418 <341383555.841/341391299.819>

When attempting to get the range of (say) column 3 (gmt col 2), nothing is reported, when using gmt gmtinfo -i2 tp.xyz.

At first, I thought it was the presence of NaNs in the data set, but the -i option reports nothing, even with small data sets.

This is with Version 6.0.0_r19127 on MacOS 10.11.6.

Thanks!

tp.xyz.gz (706 KB)


Replies (2)

RE: gmtinfo on large data sets - Added by John 11 months ago

Another little example. Given a 3x3 table, called t.txt:

5 3 8
2 9 2
7 1 4

Issuing the command: gmtinfo t.txt gives:

t.txt: N = 3 <2/7> <1/9> <2/8>

All is good. But issuing this command: gmtinfo -i1 t.txt yields no response.

And trying gmtinfo -o1 t.txt yields a NaN. Something isn't right with the -i and -o options.

A work around is to use: awk ' { print $2 } ' t.txt | gmtinfo which gives:

<Standard Input>: N = 3 <1/9>

Thanks for resolving.

RE: gmtinfo on large data sets - Added by Paul 11 months ago

Good one. The new first-record parser foolishly thought NaN was the start of trailing text. Fixed in r19236.

(1-2/2)