Landmass not filled "continuously"

Added by Christoph 10 months ago

Hey folks,

hoping for your help as I have been trying to resolve this issue for quite a while now. I am a GMT newbie, currently trying to plot a map of Antarctica.

Minimal sample code:
gmtset PS_MEDIA 2200x2200
gmt pscoast -R-180/180/-90/-60 -Js0/-90/1:10000000 -P -A -BWesN -Df -W3p -Gwhite -Slightblue -K > AC.ps
gmt pscoast -R-180/180/-90/-60 -Js0/-90/1:10000000 -P -A+ag -O -BWesN -Df -Ggray >> AC.ps

Running it (GMT Version 5.4.2) gives me the desired image, but the continent is not filled continuously but there are some kind of grid lines in the fill when I zoom in (see attached image, the sea is fine though?!). I assume this is some kind of gridding/resolution issue, but cant resolve it. Does somebody know which parameter to adjust?

Thanks in advance,
Chris

gmtgrid.png (373 KB)


Replies (11)

RE: Landmass not filled "continuously" - Added by Christoph 10 months ago

I read it several times.
Application of

gmt psconvert

in several variations (also playing around with -E and -Qg) does not fix the problem (see attached image). I also looked at the outcome in various ps and pdf viewers to make sure its not a viewer problem.

Is there a way to fix this?

RE: Landmass not filled "continuously" - Added by Paul 10 months ago

I see it too. However, the " the continent is not filled continuously" has to do with filling in the ice-portion only.

RE: Landmass not filled "continuously" - Added by Joaquim 10 months ago

Well, I don't see it. I do in the PS version but not in jpeg or pdf obtained with psconvert.

RE: Landmass not filled "continuously" - Added by Paul 10 months ago

Yes, cannot rule out ghostscript regression here. I have gs 9.22.

RE: Landmass not filled "continuously" - Added by Joaquim 10 months ago

I have a home build of the release candidate of the last Ghost (Windows here. That's another difference)

RE: Landmass not filled "continuously" - Added by Christoph 10 months ago

Running gs 9.22, too.

Also, I thought it doesnt really matter to gmt that it is "ice" compared to continent, its just whether you use +Ag on the coastline or not?!

Well, if you need further information just tell me. Your help is much appreciated.

RE: Landmass not filled "continuously" - Added by Christoph 10 months ago

Another update.
Probably thats to be expected, but if I convert to png with psconvert there are setting combinations of -E and -Qg that avoid the issue and I can get output that I can use. Of course a pdf would be nicer in the long run, but it'll do for now.
Your support is much appreciated - gmt is great!

RE: Landmass not filled "continuously" - Added by Joaquim 10 months ago

You have also the alternative to take your PS file into a Windows machine and do the conversion there.

RE: Landmass not filled "continuously" - Added by Michael 10 months ago

You can also find a number of other Antarctica datasets on the net, which are not gridded, e.g.:

http://www.antarcticglaciers.org/antarctica/antarctic-datasets/

http://download.geofabrik.de/antarctica.html

and others.

RE: Landmass not filled "continuously" - Added by Paul 10 months ago

What OS are you using? On OS X, Apple changed how Preview works a few years ago and there is no longer an option to turn off (or on - cannot recall which one) anti-aliasing. Opening the PDF created by standard psconvert call on your AC.ps in Adobe Acrobat shows the same ghostlines. But Acrobat has a Preference pane where you can turn off "Smooth line art" and then the ghostlines go away. Also, when I view the raw PostScript in ghostview there are no lines. So the conclusion is that all of these things are just aliasing that some previewers are not equipped to handle, and settings may vary between OS and tools.

(1-11/11)