Maltba API of GMT5.4.3 is not working.

Added by yu 8 months ago

Maltba API of GMT5.4.3 is not working.

When I use the API, Maltab report: Invalid MEX-file 'C:\programs\gmt5\bin\gmtmex.mexw64': Can not find the Mex-file.
However, I find the gmtmex.mexw64 in the same path, then maybe this is a BUG.
My Matlab edition is 2016a, and I don't know whether the other editions have the same problems.


Replies (7)

RE: Maltba API of GMT5.4.3 is not working. - Added by Joaquim 8 months ago

Sorry, don't know what changed (in principle nothing should have changed since this is a bug fix only release) to make the mex file to fail.
Please use the attached version instead.

gmtmex.mexw64 (43.5 KB)

RE: Maltba API of GMT5.4.3 is not working. - Added by yu 8 months ago

No need to apologize, thanks for your help.

RE: Maltba API of GMT5.4.3 is not working. - Added by Paul 8 months ago

Sounds like we need to rebuild the installers?

RE: Maltba API of GMT5.4.3 is not working. - Added by yu 8 months ago

Maybe it is necessary to rebuild.
I use gmtmex.mexw64 of GMT5.4.2 to instead of the one of 5.4.3, it works well.

RE: Maltba API of GMT5.4.3 is not working. - Added by yu 8 months ago

Joaquim wrote:

Sorry, don't know what changed (in principle nothing should have changed since this is a bug fix only release) to make the mex file to fail.
Please use the attached version instead.

I tested the attached version, it doesn't work too. However, I replace the file with the one of GMT 5.4.2, it works well.

RE: Maltba API of GMT5.4.3 is not working. - Added by Joaquim 8 months ago

Hmm, I tried with the version attached above at it works for me (contrary to the one shipped with 5.4.3). That is the version that we'll use when the installer is rebuild.

RE: Maltba API of GMT5.4.3 is not working. - Added by yu 8 months ago

My matlab edition is 2016a, after that I updated to 2017b, however the error still exists, both the attached file or the original one.
In addtion, the matlab is Chinese edtion, I don't know whether it will affect the API's working.

(1-7/7)