Bug #1010

Bug with -T option in psbasemap or pscoast commands ?

Added by Cyril 4 months ago. Updated 4 months ago.

Status:ClosedStart date:2016-12-01
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.3.1 Platform:Mac OS X

Description

I want to plot a map rose with pscoast or psbasemap that shows only the N label. According to GMT 5.3.1 user manual, I wrote :

pscoast -Tdglon/lat+Wsize+f2+l,,,N

but the compilation says :

pscoast: Syntax error -T option: 4 Labels must be given via modifier +lw,e,s,n

So I can have a rose with 4 labels (with +l), or no label at all (default, without the +l option), but not with only one or two labels.
However, GMT manual says :

You can replace these labels with four custom labels via +lw,e,s,n, i.e., four comma-separated labels in the specified order. 
You can exclude any of the cardinal points from being labeled by giving no label in the corresponding order. 
E.g., +l”,,Down,Up” would write Down and Up at the south and north cardinal point, respectively.

I try also with psbasemap command, with the same results.

So it seems to be a bug.

History

#1 Updated by Paul 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Paul
  • Target version set to Candidate for next bugfix release

I can confirm that +l,,Up,Down" fails. It seems to expect +l-,-,Up,Down" so that is your workaround for now. I will work on this to allow the missing items as well.

#2 Updated by Paul 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Should be fixed in r1010 and still allows the backwards fix of passing - as empty label. But now +l",,Down,Up" works as advertised. Thanks for pointing this out!

#3 Updated by Joaquim 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF