Bug #1072

Line segments with missing segment header is not plotted (OGR/GMT)

Added by Andreas 5 months ago. Updated 5 months ago.

Status:ClosedStart date:2017-03-21
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.3-svn Platform:

Description

This may not be an issue, but maybe you would like to know;

I converted a line shapefile with ogr2ogr. Only some of the line segments got their own segment header, # @D(..) (in my specific case, this was because the attributes given in a segment header applied to all lines down to the next segment header). This causes GMT to only draw the lines that have this segment header. This only applies to files with an OGR/GMT header. If you remove this header (everything above the first >) GMT plots it all.

This 'problem' only applies to line files, not point or polygon files.

See example. In the <..>_h.gmt files, I've removed all segment headers except the 1st.

Tested on 5.3.2

lines.gmt (660 Bytes) Andreas, 2017-03-21 07:17

lines_h.gmt (642 Bytes) Andreas, 2017-03-21 07:17

ogr.pdf (6.31 KB) Andreas, 2017-03-21 07:17

point.gmt (459 Bytes) Andreas, 2017-03-21 07:17

point_h.gmt (447 Bytes) Andreas, 2017-03-21 07:17

poly.gmt (924 Bytes) Andreas, 2017-03-21 07:17

poly_h.gmt (902 Bytes) Andreas, 2017-03-21 07:17

script.bat (390 Bytes) Andreas, 2017-03-21 07:17

Associated revisions

Revision 17742
Added by Paul 5 months ago

Address issue #1072

History

#1 Updated by Paul 5 months ago

  • Status changed from New to Resolved
  • Assignee set to Paul
  • Target version set to Candidate for next bugfix release
  • % Done changed from 0 to 100

There as an assumption of always having at least one comment OGR line after the segment header, so the first record got eaten if that was not the case. Now being more careful and checking and things work. In r17742

#2 Updated by Joaquim 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF