Bug #1092

psscale bug

Added by Tim 3 months ago. Updated 2 months ago.

Status:ClosedStart date:2017-05-10
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next minor release
Affected version:all Platform:Linux

Description

When running the commands:

echo -e "98 black 100 black\n100 white 108 white" > tmp.cpt
gmt psscale -JX20cT/10c -R2016-04-01T/2016-04-15T/8.1/8.25 -Dn0.5/0.9+w10c/0.8c+jMC+h -B1 -Ctmp.cpt > out.ps

I get the attached figure. This doesn't contain the correct range of values specified in the cpt. Any ideas?

out.ps (20.7 KB) Tim, 2017-05-10 04:51

Associated revisions

Revision 18275
Added by Paul 3 months ago

Address issue #1092

History

#1 Updated by Paul 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Paul
  • Target version set to Candidate for next minor release
  • Affected version changed from 5.2.x to all

I can confirm the problem. I assume -B settings relevant to the time axis are interfering in the labeling of the linear CPT axis. As a workaround leave the -B off and you get what you expect (but you then only get the CPT boundaries labeled). We will look into a fix.

#2 Updated by Paul 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Fixed in r18276. Had to re-parse the -B option settings when -R -J were given since those may be log or (as here) time axes which will cause trouble for the bar annotation.

#3 Updated by Paul 2 months ago

  • Status changed from Resolved to Closed

Closed as fixed.

Also available in: Atom PDF