Feature #1123

Bounding box polygon with gmtinfo

Added by Andreas 5 months ago. Updated 13 days ago.

Status:ClosedStart date:2017-06-25
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next minor release
Platform:

Description

grdinfo -Ib <grid>

is a great way of making a grid(s) bounding box polygon. Would the exact same thing be possible to implement in gmtinfo?

gmtinfoib.pdf (181 KB) Andreas, 2017-07-02 01:31

gmtinfoib.sh Magnifier (391 Bytes) Andreas, 2017-07-02 01:31

faults.gmt (1.46 MB) Andreas, 2017-07-02 01:32

Associated revisions

Revision 18467
Added by Paul 5 months ago

Add -Ib to gmtinfo, issue #1123

History

#1 Updated by Paul 5 months ago

  • Status changed from New to In Progress
  • Assignee set to Paul
  • Target version set to Candidate for next minor release

Yes, maybe later this week.

#2 Updated by Paul 5 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Should be working in r18467.

#3 Updated by Andreas 5 months ago

Great Paul.

I've tested it with r18505, and the southern boundary line seems to be a bit off? Included an example in mercator and stereographic projection.

#4 Updated by dan about 1 month ago

(Spam removed)

#5 Updated by Paul 22 days ago

Sorry this took so long to respond to. You should use -Ap when plotting this box, otherwise it will draw great circle lines as you indicated.

#6 Updated by Paul 17 days ago

  • Status changed from Resolved to Closed

Believe this is working as intended. Updated the documentation to point out the need for -Ap when plotting this polygon with psxy. Closing the issue.

#7 Updated by Andreas 13 days ago

Did not specify -Ap as you pointed out.

Works perfectly!

Also available in: Atom PDF