Bug #1160

grdimage logarithmic x-axis

Added by Kristin about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:2017-10-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected version:all Platform:Windows

Description

Hi!

I'm using GMT 5.3.3 r15178 (64-Bit, Windows).

I want to add a logarithmic x-axis to a 2-dimensional diagram, using grdimage (with -JX2cl/-10c) and I obtain the following error message:

"grdimage: Syntax error -JX:x option: Limits must be positive for log10 option."

Bug #1082 reported a similar problem with the command pshistogram, which was fixed in the follow-up version.
Does the command grdimage have the same kind of issue?

History

#1 Updated by Kristin about 1 month ago

Sorry, I'm working on Linux Ubuntu, not on Windows.

#2 Updated by Joaquim about 1 month ago

  • Priority changed from High to Normal

If you are asking a question why did you open a bug report? Specially since you are not using the latest release.

#3 Updated by Kristin about 1 month ago

I take it from your response that the issue has been fixed in the latest release?

I asked, because I'm working from a university computer and can't easily change between releases without authorization.

#4 Updated by Joaquim about 1 month ago

Kristin wrote:

I take it from your response that the issue has been fixed in the latest release?

Don~t know if it was fixed or not. You didn't provide an example that we can quickly check. True that I could try to reproduce from the description but we also have a lot more things to do.

I asked, because I'm working from a university computer and can't easily change between releases without authorization.

It is fine to ask questions, but we have a forum for that. Bug reports should be used more carefully.

#5 Updated by Kristin about 1 month ago

Okay, I'll use the forum next time. Sorry for the inconvenience!

#6 Updated by Joaquim about 1 month ago

Good, but please provide at least an example of the failing command.

#7 Updated by Paul about 1 month ago

  • Project changed from GMT Custom to GMT

Bigger problem is that you were posting in the GMT Custom place and not to GMT itself. I have moved it. Please add an example to the forum.

#8 Updated by Paul about 1 month ago

  • Status changed from New to Closed
  • Affected version changed from 5.3-svn to all

Closing this issue because of lack of follow-up with example. Please repost if you have a reproducible problem.

Also available in: Atom PDF