Bug #1176

Problem running Matlab API after updating Matlab

Added by Marc over 1 year ago.

Status:NewStart date:2017-12-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected version:5.4.2 Platform:Mac OS X

Description

Dear all,

I am have updated GMT to gmt 5.4.2 and now I am having some troubles running some old Matlab scripts for which I use the gmt commands.

When I run the surface command I get a grid file (matlab.grd) which is not later recognised as a grd with correct format. For example, I get the following error when I try to use grdimage.
grdimage (api_import_grid): Not a supported grid format*

However, when I run the same commands from the terminal I have no problem and I obtain the terminal.grd file form which I can create my map.

I tried to update my matlab API following http://gmt.soest.hawaii.edu/projects/gmt-matlab-octave-api/wiki but when I type gmt in matlab I get the following message:
GMT - The Generic Mapping Tools, Version 5.3 API
Copyright 1991-2016 Paul Wessel, Walter H. F. Smith, R. Scharroo, J. Luis, and F. Wobbe

So it looks like maybe the gmt 5.4.2 APPI is not installed correctly and Matlab is still using my older installation. Might this be the problem?.Is there a way I can completely remove my previous API installation and configure matlab with gmt 5.4.2?

Thanks in advance,

terminal.grd (160 KB) Marc, 2017-12-14 03:05

matlab.grd (820 KB) Marc, 2017-12-14 03:05

Also available in: Atom PDF