Bug #1211

figure modern mode fails when parsing -P to psconvert

Added by Jose 3 months ago. Updated 3 months ago.

Status:ClosedStart date:2018-03-08
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:-
Affected version:6.x-svn Platform:

Description

Dear developers,

I am starting to use the new gmt modern mode.

In my first script I am trying to make a situation map of the Philippines:

gmt begin
gmt figure tectonic_map png,pdf P,A0.2c,Qg4,Qt4
gmt coast -RPH+r0.2 -JEqc/238/13c -Di -Wthick -A100/0/1 -Bafg
gmt end

Everything works fine but the "-P" parsing from figure command to psconvert, and gmt complains:
figure [ERROR]: Unrecognized psconvert option -P

The figure in classic mode is produced correctly.

tectonic_map_classic.png (117 KB) Jose, 2018-03-08 10:13

tectonic_map_modern.png (124 KB) Jose, 2018-03-08 10:13

History

#1 Updated by Paul 3 months ago

P is not a valid option in modern.

#2 Updated by Jose 3 months ago

Paul wrote:

P is not a valid option in modern.

Ok, thanks Paul,

Then it should be deleted from the help

Of course the figure obtained can be rotated manually but it was nice to have the figure just right out of the box!


    <psconvertoptions> contains one or more comma-separated options that
       will be passed to psconvert when preparing this figure [A].
       The valid subset of psconvert options are

         A[<args>],C<args>,D<dir>,E<dpi>,H<factor>,Mb|f<file>,P,Q<args>,S
       See the psconvert documentation for details.

#3 Updated by Paul 3 months ago

  • Status changed from New to Resolved
  • Assignee set to Paul
  • % Done changed from 0 to 100

Right, it was removed from the docs but lived on in the usage...Now removed in r19898. There should not be any need to rotate any figure unless you really want it to be side-ways or upside down, no?

#4 Updated by Jose 3 months ago

Ops, then I am having a different problem. My figures produced in modern mode are rotated.

Figures produced are attached.

The codes are:
Classic:

pscoast -RPH+r0.2 -JEqc/238/13c -Di -Wthick -A100/0/1 -Baf > tectonic_map_classic.ps
psconvert tectonic_map_classic.ps -Tg -P -A0.2c

Modern:
gmt begin
gmt figure tectonic_map_modern png A0.2c
gmt coast -RPH+r5 -JEqc/238/+13c -Baf -BWESN -Di -Wthick -A100/0/1
gmt end

#5 Updated by Paul 3 months ago

OK, will look. May be something about you specifying -A and somehow the (internal) P is dropped.

#6 Updated by Paul 3 months ago

Hm, I cannot reproduce your result. Both with or without -A in figure gives the same result. Wonder if there is some interference with a gmt.conf since you clearly have different settings than me (I get a fancy border you get lines).

#7 Updated by Jose 3 months ago

You are right!!

I had an old (gmt 5.4) gmt.conf on my home directory. I deleted it and everything works well.

Thank you Paul.

#8 Updated by Paul 3 months ago

  • Status changed from Resolved to Closed

Closed as fixed.

Also available in: Atom PDF