Bug #1253

dcw/gshhg - Ireland

Added by James 3 months ago. Updated 5 days ago.

Status:ClosedStart date:2018-06-20
Priority:NormalDue date:
Assignee:Paul% Done:

0%

Category:-
Target version:Candidate for next minor release
Affected version:5.4.2 Platform:

Description

garbled output when trying to highlight Ireland in pscoast using the -E option

pscoast -EIE+ggreen

test.png - garbled output (114 KB) James, 2018-06-21 04:57

test1.png - widened region (98.5 KB) James, 2018-06-21 04:58

History

#1 Updated by Paul 3 months ago

This works for me:

gmt pscoast -EIE+ggreen -JM6i -P -Baf > t.ps

#2 Updated by Paul 3 months ago

So that was trunk (6.0.0). RUnniing your command in 5.4.x gives an error:

pscoast -EIE+ggreen
pscoast: Syntax error: Must specify -R option
pscoast: Syntax error: Must specify a map projection with the -J option

#3 Updated by James 3 months ago

apologies – incomplete mwe
using version 5.4.2 on Fedora 28

#!/bin/bash

R=-10/20/35/60
J=N1/21c
OUT=test.ps
gmt pscoast -R$R -J$J -Ggrey -Wdarkgrey -EIE+gcornsilk > $OUT
gmt psconvert -Tg -A -P -Z $OUT

produces the attached file test.png

I think the problem is when the -E option is used and the target country (in this case with lots of islands) has some regions outside the -R option.
Moving -R to -15/20/35/60 (as in attached test1.png) and then cropping the resulting image to get the desired size solves the issue but is not ideal.

#4 Updated by Paul 3 months ago

  • Status changed from New to Feedback
  • Assignee set to Paul
  • Target version set to Candidate for next minor release

The good news this is fixed in trunk. The bad news is that we cannot easily back-port the solution to the old GMT5 branch, hence the next 5.4.4 will still have the same problem (but 6.x does not). So if you build from source then you are OK, otherwise you will need to do your workaround until 6.0.0 is released probably late this year.

#5 Updated by James 3 months ago

Thanks Paul
Successfully installed from trunk. Really like the "modern" session controls. Miss the man pages though.

Excellent program. Please keep up the good work. All that's missing to make it perfect is full utf8 support – but I understand the problem.

#6 Updated by Joaquim 5 days ago

  • Status changed from Feedback to Resolved

#7 Updated by Joaquim 5 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF