Feature #232

Annotations in BASEMAP_TYPE=inside mode are clipped in its limits

Added by Billy over 4 years ago. Updated over 2 years ago.

Status:ClosedStart date:2013-04-01
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Platform:

Description

When it is selected an inside mode for BASEMAP_TYPE, the minimum and maximum latitude and longitude annotations are clipped. An example command to see the issue is below:

pscoast -V -R-180/180/-90/90 -B90g90 -JX6.82id/3.41id -P -Sgray > test.ps

Billy

History

#1 Updated by Joaquim about 4 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Feedback

This is not a bug and IMO that's the way it should behave because if we move those labels they won't be aligned with the tick marks the same way as the others.

#2 Updated by Billy about 4 years ago

Dear Joachim,

Ok, so I think it would be a solution not set the labels if the ticks and their labels coincide with the limits of the map. I'm not sure if this could work out the issue and I've based this suggestion in the example that I presented above.

Billy

Joaquim wrote:

This is not a bug and IMO that's the way it should behave because if we move those labels they won't be aligned with the tick marks the same way as the others.

#3 Updated by Joaquim about 4 years ago

Yes, not printing them at all would a good solution.

#4 Updated by Paul almost 3 years ago

  • Status changed from Feedback to Resolved
  • Assignee set to Paul
  • Target version set to Candidate for next bugfix release
  • % Done changed from 0 to 100

Full speed ahead on this one...
I have implemented the simple fix that we skip annotations that coincide with the boundaries. It is not ideal but it will at least minimize such clipping issues. In r13937.

#5 Updated by Remko over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF