Bug #434

grdvector -I is misbehaving

Added by Paul over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:2013-11-08
Priority:HighDue date:
Assignee:Paul% Done:

0%

Category:-
Target version:Candidate for next bugfix release
Affected version:all Platform:

Description

The -I option used to have no checking and could crash for incorrect arguments, but the check we added fails when trying to determine if the desired vector interval is a multiple of the grid interval.

Associated revisions

Revision 12477
Added by Paul over 3 years ago

Fix issue #434 and add new test for this case

History

#1 Updated by Paul over 3 years ago

  • Status changed from New to Resolved

Should be fixed in GMT 4 (r10147 ) and GMT5 (r12477); added new test for grdvector to test this case.

#2 Updated by Florian over 3 years ago

I get a fail because the annotations (minus sign) are different: grdvector/sample.ps: RMS Error = 0.016 [FAIL]

#3 Updated by Paul over 3 years ago

Old PS, now updated.

#4 Updated by Paul over 3 years ago

Actually, there was one more bug. For geographic grids using the new geovector, the directions obtained from dx, dy were not converted to azimuths first. Also, -T is not valid with geographic data (no checking and giving a warning). In r12490; not sure what that does to your macports build update.

#5 Updated by Florian over 3 years ago

Too late, this fix is not included now. But when someone complains I can submit another patch.

#6 Updated by Paul over 3 years ago

  • Status changed from Resolved to Closed

Fixed a while ago, now closed.

Also available in: Atom PDF