Bug #460

psxyz doesn not respect -E in compatibility mode

Added by Joaquim over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:2013-12-12
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.x-svn Platform:

Description

While tracking another issue I noticed that a modified form of ex08 (basically, turned into a single command) errors if -E instead of -p is used.

gmt psxyz lixo.dat -B1 -Bz1000+l"Topography (m)" -BWSneZ+b+tETOPO5 -R-0.1/5.1/-0.1/5.1/-5000/0 -JM5i -JZ6i -E200/30 -So0.0833333ub-5000 -P -Wthinnest -Glightgreen -K > lixo.ps
psxyz: Option -E is not a recognized common option

I did a bit of debugging and it seams the problem is that in

GMT_parse_common_options (struct GMT_CTRL *GMT, char *list, char option, char *item)
...
        switch (option) {
            case 'E': GMT_COMPAT_OPT ('p'); break;

the transmitted "*list" has only the character 'E' so the GMT_COMPAT_OPT macro fails to set 'optioni to 'p'

Associated revisions

Revision 12630
Added by Paul over 3 years ago

Fix issue #460

History

#1 Updated by Paul over 3 years ago

  • Status changed from New to Resolved

The GMT_COMPAT_OPT macro checked for the wrong option. Fixed in r12630.

#2 Updated by Paul over 3 years ago

  • Status changed from Resolved to Closed

Presumably fixed so closing it.

Also available in: Atom PDF