Feature #533

Simplify calculation of oblique map domain perimeter

Added by Paul about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:2014-04-02
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next minor release
Platform:

Description

When using oblique projections we often wish to show the oblique domain on another map. This involves situations when -R -J is given with the -R<llx/lly/urx/ury>r specification. Turns out this is difficult to do in GMT without considerable scripting. My suggestion is to add a new option to mapproject, i.e. -W[nx/ny] which would require -R...r -J [ -C ] and no input file and simply write out the geographic coordinates of the oblique domain sampled as frequently as specify by the number of points along the two sides. Internally, we have 0,0 as the lower-left projected point, obtain X,Y of the upper-right projected point, then sample the four sides in a counter-clockwise direction and inverse project these coordinates to obtain lon,lat, which we then write to stdout.
Alternatively, it could be a new option for psbasemap to save the perimeter it draws in geographical coordinates to a specified file.

History

#1 Updated by Paul about 3 years ago

  • Status changed from New to Resolved

This request has been implemented in GMT 5.2 via a new option -A[<file>] to psbasemap, which instead of plotting a map
will write the coordinates of the plot domain outline to the given file (or stdout).

#2 Updated by Paul about 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Closing this as the option works as intended.

Also available in: Atom PDF