Bug #616

Grdfilter issue with rescaling output grid

Added by Matthew over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:2014-09-09
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:all Platform:

Description

Running grdfilter with -I < input increment produces odd behaviour. Increasing the spacing works fine in the x direction, but the y direction keeps the appearance of original input spacing. Upon closer inspection, the new points have been created, but not interpolated

I can achieve the desired result ( point –> Gaussian blob) if I run grdfilter rotate the grid 90 degrees, and run it again, but that seems wrong that I should have to do this manually. Am I missing something?

The following script generates a single point, and shows the result of grdfilter.

#!/bin/bash

echo "0.5 0.5 1" | xyz2grd -N0 -I0.1 -An -Gtemp.grd -R0/1/0/1

grdfilter temp.grd -Gtemp2.grd -R0/1/0/1 -I0.01 -D0 -Fg0.5

grd2cpt temp2.grd -E100 -D -Cjet > sn.cpt

grdimage temp2.grd -R0/1/0/1 -B0.1 -JX5i -K -Csn.cpt > filter.ps

grdimage temp.grd -R0/1/0/1 -B0.1 -JX5i -O -Csn.cpt -Y6i >> filter.ps

evince filter.ps

issue.jpg - The issue illustrated (39.4 KB) Matthew, 2014-09-09 03:50

Associated revisions

Revision 13525
Added by Paul over 2 years ago

Adding test script to ensure issue #616 is fixed

History

#1 Updated by Matthew over 2 years ago

Sorry - Should have added I have tried this on various machines, with GMT 4.5.[6,7,8,11]

#2 Updated by Paul over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Paul
  • Affected version changed from 4.5.x to all

I can confirm the bug and will be working on it. It affects both GMT4 and 5.

#3 Updated by Paul over 2 years ago

  • Status changed from In Progress to Resolved
  • Target version set to Candidate for next bugfix release
  • % Done changed from 0 to 100

I have fixed this problem in GMT 4 (r10260) and GMT 5 (r13511). As pointed out, it only affected the y-direction. Let us know if it works for you.

#4 Updated by Paul over 2 years ago

  • Status changed from Resolved to Closed

Closing this issue; test script filtersample.sh has been added to ensure it will not return.

Also available in: Atom PDF