Bug #621

grdimage

Added by Peeter about 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:2014-09-10
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.1.1 Platform:Linux

Description

Segfault when using grdimage with intensities (-I) option.
The latest version of gmt_bcr.c (issue #620) did not help.

commands :

gmt grdgradient gridsurface.nc -E315/40 -Ggridintens.nc -V :
gmt grdimage gridsurface.nc -Cbathy.cpt -Igridintens.nc -Jl24/57.51755393056/58/59.3333333333/1:5000 -V3 > gridsurfimage.ps

Works OK if not using -I option.

OS : Linux (Ubuntu 14.04), gmt compiled from source.

gridintens.nc - intensities (1.62 MB) Peeter, 2014-09-10 21:58

gridsurface.nc - surface grid (1.61 MB) Peeter, 2014-09-10 21:58

bathy.cpt - color table (11.8 KB) Peeter, 2014-09-10 21:58

History

#1 Updated by Paul about 3 years ago

  • Status changed from New to Feedback

Frustrating. I am trying this on ubuntu 13.10 with GMT r13516 and have no problems. So grdimage - says r13516 ? I am upgrading to 14.04 now...

#2 Updated by Joaquim about 3 years ago

No problems here either
- Windows 5.2 dev
- Lubuntu 14.04 trunk

#3 Updated by Paul about 3 years ago

Updated ubuntu to 14.04, using latest GMT 5 and GMT4 revisions. No crashes. Not sure what is wrong with your setup; I am unable to reproduce this issue. Others?

#4 Updated by Eduardo about 3 years ago

No crashes on Debian Jessie 32 bits with GMT r13525

#5 Updated by Peeter about 3 years ago

Solved

I tried to update old 5.1.1 with new gmt_bcr.c and gmt_constants.h -
did not work.
Now got full SVN latest version and all is OK.

#6 Updated by Paul about 3 years ago

  • Status changed from Feedback to Closed

Closing this issue as a non-issue.

#7 Updated by Awen over 2 years ago

Edit: Junk removed.

Also available in: Atom PDF