Bug #749

Problem with horizon factor in orthographic and stereographic plots

Added by Richard about 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2015-08-12
Priority:NormalDue date:
Assignee:Paul% Done:

0%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.1.x Platform:

Description

Hi All,

I'm trying to implement a very simple "zoom" feature by utilizing the horizon parameter of the orthographic projection (documentation excerpt below):

-JGlon0/lat0[/horizon]/width, where
horizon specifies the max distance from projection center (in degrees, ⇐ 90, default 90).

Using the version 5.1.2 GMT interface, I made 2 plots with the following psbasemap parameters:
1) psbasemap -R-180/180/0/90 -JG0.000000/90.000000/90.000000/6.0i ...
2) psbasemap -R-180/180/0/90 -JG0.000000/90.000000/9.000000/6.0i ...

I had expected plot 2) to be a magnified version of plot 1) since the horizon parameter is set 10x smaller. However, the plots came out identical. This is the case with the stereographic projection as well (-JS).

However, when I used this same technique with the gnomonic projection (-JF) it produced a magnified plot as I had expected!

Any suggestions?

Thank you,

Rick Carlson

History

#1 Updated by Paul about 2 years ago

  • Status changed from New to In Progress

Leaving on vacation and cannot easily follow up but: The only projection that is not from infinity is the General Perspective (-JG with a bunch of arguments; see docs). Going -JG and a size means the plot will b that size regardless of -R etc. Gnomonic is different since it actually projects from the center of the globe.

#2 Updated by Paul almost 2 years ago

  • Status changed from In Progress to Closed
  • Assignee set to Paul
  • Target version set to Candidate for next bugfix release

Since this is not a bug but a feature I will close this issue.

Also available in: Atom PDF