Bug #845

manpages: Synopsis error

Added by Ludwig about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:2016-01-11
Priority:NormalDue date:
Assignee:Remko% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.x-svn Platform:

Description

I just updated gmt5 SVN to 5.3.0_r15433 on Ubuntu 14.04.3 LTS (x86_64). After building and installing the manpages, the capital option letters (-R,-J,...) in SYNOPSIS were missing.
man psxy
now gives:
SYNOPSIS
psxy [ table ] parameters west/east/south/north[/zmin/zmax][r] [ [m|p|x|y] ] [ [p|s]parameters ] [ cpt ] [ dx/dy ]
[ [x[+]|y[+]|X|Y][n][cap][/[-|+]pen] ] ...

It looks like all manpages are affected.

History

#1 Updated by Paul about 1 year ago

  • Status changed from New to Resolved

I just did the full build and man pages are find. I think this is a problem with your sphinx version. I am running 1.2.3 since the most recent version has a bug that has not been fixed in the distros yet.

#2 Updated by Ludwig about 1 year ago

Well, as I'm working at Ubuntu LTS from 2014, I have sphinx version "1.2.2+dfsg-1ubuntu1.1" installed (= default from Ubuntu 14.04 repositories). Anyway building the manpages was working pretty fine until my last gmt5 svn update (around middle of december).

#3 Updated by Paul about 1 year ago

Try svn update and see if things improve. Many changes since mid December, but as I said it worked fine this morning for me.

#4 Updated by Ludwig about 1 year ago

Maybe I wasn't precise enough. I ment it worked fine all the time (including the last update mid December) and now (updated today to r15433) it's not working anymore.

#5 Updated by Paul about 1 year ago

  • Status changed from Resolved to In Progress

Thanks, that is clear, but makes it a bit stranger. I will wait for others on the team to check since I have not made any changes that would effect this in a long while.

#6 Updated by Joaquim about 1 year ago

Is this the manpages PDF version? If yes, than yes this is an known issue.

#7 Updated by Ludwig about 1 year ago

No, it is the command-line version (as already said e.g. man psxy gives the reported result).

#8 Updated by Paul about 1 year ago

  • Target version set to Candidate for next bugfix release

I can confirm the man pages misses leading options like -R in the documentation. Looks like the |SYN_OPT-R| macros completely skips the |-R| part. Joaquim, did this part change? In contrast, the |SYN_OPT_...| macro for -a use a leading -a with those double stars and that comes through in bold.

#9 Updated by Joaquim about 1 year ago

The macros for the lower case options do not use the |-?| macro and so they are unaffected. I have tried to workaround this issue with the .. only:: latex RST construct but it simply ignores me so I don't see any other solution but to have two common_SYN_OPTs.rst_ files. One with |-R| and the other with -R

#10 Updated by Remko about 1 year ago

  • Status changed from In Progress to Closed
  • Assignee set to Remko
  • % Done changed from 0 to 100

I solved this with r15753.
A bit circuitous, but it does work.
Joaquim verified.

Also available in: Atom PDF