Bug #857

Patch to fix build on sparc

Added by Bas over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:2016-02-19
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.2-svn Platform:Linux

Description

With the untangled circular dependencies preventing GDAL updates, the GMT build dependencies became installable on the Debian sparc64 port.

Like the alpha (#819), hppa (#818), mips & kfreebsd (#720) architectures, common_sighandler.c needs a patch to support the specific register for the instruction pointer on sparc.

The attached patch support both the old 32bit sparc and new 64bit sparc64 ports. The 32bit support is unlikely to be used because the sparc port has been discontinued in Debian, but the sparc64 port is being developed to take its place and is the primary reason for this patch. The patch may also benefit OpenBSD which does still support 32bit sparc IIRC.

sparc-sighandler.patch Magnifier (635 Bytes) Bas, 2016-02-19 01:49

History

#1 Updated by Paul over 1 year ago

  • Status changed from New to Resolved
  • Assignee set to Paul
  • % Done changed from 0 to 100

Thanks, included in r15739.

#2 Updated by Paul over 1 year ago

  • Status changed from Resolved to Closed

Completed.

Also available in: Atom PDF