Support #903

error when processing sample data

Added by NING over 3 years ago. Updated over 3 years ago.

Status:NewStart date:2016-05-11
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I have tried to process several samples downloaded from "http://topex.ucsd.edu/gmtsar/downloads/" but still have almost same error, "grdinfo: Error for input file: No such file (xxx.grd)" or "grdmath: Syntax error: xxx.grd is not a number, operator or file name".

I can not figure out where the problem is, although I have read on web page "https://mailman.ucsd.edu/pipermail/gmtsar-l/2012-March.txt" that XiaoPeng said "The intf_batch.csh had a bug (it didn't generate topo_shift.grd automatically) and I attached the fixed script here. I will update the GMTSAR in the next version." and David said "You map need to make the topophase separately. Xiaopeng would know the details."

I am sure that $PATH on my Ubuntu system has no path pointing to GMTSAR but to "/usr/local/GMT5SAR/bin", and "dcw" files are in directory "/usr/local/dcw-gmt-1.1.2", "gshhg" files are directory in "/usr/local/gshhg-gmt-2.3.4", "orbit" files are in directory "/usr/local/orbits". I am not sure GMT5SAR batch commands can find "dcw", "gshhg" and "orbits" files because I did not have an instruction to set $PATH or similar variables to tell where they are for GMT5SAR.

One of log files is attached. Please help!

01err7.txt Magnifier (29.2 KB) NING, 2016-05-11 11:57

01err8.txt Magnifier (30.2 KB) NING, 2016-05-16 09:45

01err9.txt Magnifier (29.7 KB) NING, 2016-05-17 12:12

History

#1 Updated by Paul over 3 years ago

Try to run with verbose, e.g.,
csh -xv <fullpathto>/p2p_ALOS.csh IMG-HH-ALPSRP207600640-H1.0__A IMG-HH-ALPSRP227730640-H1.0__A config.alos.txt
so you can see what argument is not being set, causing filter.csh to fail.

#2 Updated by NING over 3 years ago

Hi, Paul,

Thank you for the method to find the un-set arguments!

In the attached log file( line 556 ), it shows
—--
filter.csh IMG-HH-$ref.PRM IMG-HH-$rep.PRM $filter $dec
filter.csh IMG-HH-ALPSRP207600640-H1.0__A.PRM IMG-HH-ALPSRP227730640-H1.0__A.PRM 2
—--
either $filter or $dec is not set before calling "filer.csh". By my knowledge they should be set automatically somewhere in so many existing ".csh" files. I can not figure out where is the correct place to set the value of them manually, and I know the setting may cause side-effects to other ",csh" in their existing scope.

Because this is processing the sample data and I do not familiar with the structure of the GMT5SAR software, may you tell the developers of GMT5SAR to have a check on processing their sample data?

Thank you for the help!

Ning.

#3 Updated by Paul over 3 years ago

Well, since I do not use GMT5SAR for my research I have no experience with it other than running the test case, which worked for me. Hopefully, some of the GMT5SAR developers/users can help you out. My suspicion would be taht your config file does not list the filter setting.

#4 Updated by NING over 3 years ago

Hi, Paul,

Thank you for your suspicion that gives me a hint to check the filter configurations of GMT5SAR!

In the package of the first sample "(01ALOS1L1p0stdFmtCEOS)ALOS_Baja_EQ" on web page "http://topex.ucsd.edu/gmtsar/downloads/", there are 2 files, "config.alos.txt" and "config.alos.txt_gmt4", to specify many parameters to process the data. I believe "config.alos.txt" is for GMT5SAR that I am currently using, "config.alos.txt_gmt4" is for GMTSAR that I also have installed but cleared any of its path in all enveronmental variable.

For the filter, "filter1 = gauss_alos_200m" is specified in "config.alos.txt_gmt4" and there are 2 files, "gauss_alos_200m" and "gauss_alos_200m.m", in directory "/usr/local/GMTSAR/gmtsar/filters". But in "config.alos.txt" there is only "filter_wavelength = 260" specified and no "gauss_alos_260m" and "gauss_alos_260m.m" files in directory "/usr/local/GMT5SAR/gmtsar/filters". I guess "filter_wavelength = 200" should be correct, but I get the same error as before( please see the attached file ).

May you contact the developer of GMT5SAR for my issue? I submit issue #900 and #903 to them but no reply from them.

Thank you for the help!

Ning.

Also available in: Atom PDF