Bug #964

gmt convert -i does not work with non-geographic GMTOGR tables

Added by Florian 10 months ago. Updated 3 months ago.

Status:ClosedStart date:2016-09-09
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Affected version:5.x-svn Platform:

Description

This fails:

gmt convert -aconduct,depth,salinity,sonicspeed,temp utm.gmt

With the following input file utm.gmt:

# @VGMT1.0 @GPOINT
# @R573832.189086/576690.67266/6018983.52964/6022202.53071
# @Jp"+proj=utm +zone=32 +datum=WGS84 +units=m +no_defs " 
# @Jw"PROJCS[\"WGS_1984_UTM_Zone_32N\",GEOGCS[\"GCS_WGS_1984\",DATUM[\"WGS_1984\",SPHEROID[\"WGS_84\",6378137,298.257223563]],PRIMEM[\"Greenwich\",0],UNIT[\"Degree\",0.017453292519943295]],PROJECTION[\"Transverse_Mercator\"],PARAMETER[\"latitude_of_origin\",0],PARAMETER[\"central_meridian\",9],PARAMETER[\"scale_factor\",0.9996],PARAMETER[\"false_easting\",500000],PARAMETER[\"false_northing\",0],UNIT[\"Meter\",1]]" 
# @Nconduct|depth|salinity|sonicspeed|temp
# @Tdouble|double|double|double|double
# FEATURE_DATA
# @D0.728000000000000|8.300000000000001|0.459000000000000|1492.476000000000113|12.802000000000000
573832.189085956 6018983.5296434
# @D0.995000000000000|8.500000000000000|0.634000000000000|1492.798000000000002|12.831000000000000
573832.189085956 6018983.5296434
# @D1.296000000000000|8.600000000000000|0.838000000000000|1492.780999999999949|12.760999999999999
573832.189085956 6018983.5296434

Output:

gmtconvert: Column selected for latitude-formatting has values that exceed +/- 90; set to NaN
[...]
-7.81091404404  NaN     0.728   8.3     0.459   1492.476        12.802
-7.81091404404  NaN     0.995   8.5     0.634   1492.798        12.831
-7.81091404404  NaN     1.296   8.6     0.838   1492.781        12.761
[...]

Adding -f does not help. gmtconvert should be able to deal with any coordinate system.

History

#1 Updated by Paul 9 months ago

  • Status changed from New to Feedback

I dont get it. When I run your command I get

573832.189086    6018983.52964    0.728    8.3    0.459    1492.476    12.802
573832.189086    6018983.52964    0.995    8.5    0.634    1492.798    12.831
573832.189086    6018983.52964    1.296    8.6    0.838    1492.781    12.761

Also, I assume typo (-i) in the title of the issue?

#2 Updated by Florian 6 months ago

  • Status changed from Feedback to Resolved

I dont get it. When I run your command I get
[...]

I cannot reproduce it anymore so I guess it got fixed already.

#3 Updated by Joaquim 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF