Bug #990

gmtmath COL operator always selects 1st column

Added by Paul 6 months ago. Updated 6 months ago.

Status:ClosedStart date:2016-10-29
Priority:NormalDue date:
Assignee:Paul% Done:

100%

Category:-
Target version:Candidate for next bugfix release
Affected version:5.x-svn Platform:

Description

gmt math's COL operator select column 0 (the first) and not 4 (the 5th):

cat both.txt:
197.26    -14.7969    2    2    -0.2
195.455    -15.6029    4    4    -0.4
194.666    -15.8107    6    6    -0.6
...
gmt math both.txt -Ca 4 COL ADD =
394.52    182.4631    199.26    199.26    197.06
390.91    179.8521    199.455    199.455    195.055
389.332    178.8553    200.666    200.666    194.066
...

The problem is lack of parenthesis around the assignment from factor in integer.

History

#1 Updated by Paul 6 months ago

  • Status changed from New to Resolved
  • Assignee set to Paul
  • % Done changed from 0 to 100

Fixed in r17273.

#2 Updated by Paul 6 months ago

  • Status changed from Resolved to Closed

Closed as fixed.

Also available in: Atom PDF